
PageMate ® V3.3-0 
Change History 

New builds of PageMate software are provided from time to time to resolve problems or 
provide minor changes in functionality within a software version. New builds are posted 
to the Downloads section of the web site (www.pagemate.com) as they become available. 

You can find the software version and build for your current installation of PageMate 
software from Help->About PageMate in the program menubar or from PageMate debug 

log files. Program build numbers reflect software build date in the form yymmdd (the last 
two digits of the year, month and day of the build). 

Build Description of Change 

111111 Version 3.3-0 Production Release for Windows. 

111226 Builds of PageMate Automated Messenger (PAM) Server for Windows dated on 
or after 26 December 2011 include support for a new capability to specify the 
network port that will be used for DCE RPC connections to clients under 
ncacn_ip_tcp. 

120210 Builds of PageMate Automated Messenger (PAM) Server for Windows dated on 
or after 10 February 2012 include new support for SMPP (Short Message Peer-
to-Peer) Protocol. 

120324 Builds of PageMate Automated Messenger (PAM) Server for Windows dated on 
or after 24 March 2012 include updates in both documentation and code for 
message forwarding. A description of message forwarding functionality for both 
subscribers and groups is provided in Application Notes provided with this and 
subsequent builds. 

120423 Builds of PageMate Automated Messenger (PAM) Server for Windows dated on 
or after 23 April 2012 include new support for CCOM protocol, a wireline 
submission protocol for SMS messages broadcast by Cellcom.  

120521 Builds of PageMate Automated Messenger (PAM) Server for Windows dated on 
or after 21 May 2012 include a fix for catalog lookup code in message send 
operations in the PageMate Web Client (PamComSrv) interface. 

120625 Builds of PageMate Automated Messenger (PAM) Server for Windows dated on 
or after 25 June 2012 include a fix for problem that could result in failure to 
qualify message delivery for all members of groups with more than two 
members. 
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Build Description of Change 

120706 Builds of PageMate Server for Windows dated on or after 6 July 2012 include 
improved support for GLOBAL modem SMTP, including both support for 
GLOBAL mode SMTP in profiles (PAM only), together with fixes for GLOBAL 
mode SMTP dispatch to groups in both PageMate Classic and PageMate 
Automated Messenger Servers. This update is recommended for all sites that 
use GLOBAL mode SMTP in PageMate V3.3-0. 

120815 Builds of PageMate Server for Windows dated on or after 15 August 2012 
include improvements in program logic responsible for parsing inbound SMTP 
messages in the PageMate Electronic Mail Connector. 

120910 Builds of PageMate Automated Messenger Server for Windows dated on or after 
10 September 2012 include corrections and improvements in program logic 
responsible for processing outbound SMTP messages sourced from inbound 
SMTP, together with a fix for a problem with evaluation of MESSAGE 
statements in Qualification Criteria files under action records. 

120928 Builds of PageMate Automated Messenger Server for Windows dated on or after 
28 September 2012 include a fix for a problem dispatching SMTP messages to 
group addressees. The symptom of this problem was that delivery was being 
accomplished only to the first member of the group. This problem is fixed in 
Build 120928 and later. 

121008 Builds of PageMate Automated Messenger Server for Windows dated on or after 
8 October 2012 include a fix for a problem with Edit Group functionality in 
PageMate Administrator. The symptom of this problem was that PageMate 
Administrator would report an error or terminate abnormally after successfully 
editing the first and only group in a newly imported single-group catalog. This 
problem is fixed in Build 121008 and later. 

121110 Builds of PageMate Automated Messenger Server for Windows dated on or after 
10 November 2012 include new support for network-specific max batch, SMTP 
message batching, improved detection and reporting of SMTP error returns, and 
Registry keys QUEUE_SERVICE_INTERVAL, WCTP_2WAY and MTMP_2WAY. 
Distributions of PageMate Client dated on or after 10 November 2012 also now 
disable import and export operations when local catalogs are disabled (see 
CLIENT_CATALOGS Registry key in PageMate User’s Guide). For more detailed 
information about changes in PageMate V3.3-0 Build 121110, see Change 
History Notes for Build 121110. 

http://www.pagemate.com/downloads/doc/pagemate/V30300/Change_History_Notes_for_Build_121110.pdf
http://www.pagemate.com/downloads/doc/pagemate/V30300/Change_History_Notes_for_Build_121110.pdf
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Build Description of Change 

121220 Builds of PageMate for Windows dated on or after 20 December 2012 include a 
roll-up of changes for a variety of PageMate configurations as follows: 

PAM Server. Build 121220 includes support in PageMate Administrator 
Command Line Interface for a new /SORT=NETWORK option in conjunction 
with /QUEUE=PAGE for EXPORT and PRINT commands. This option supports 
reporting message history for any arbitrary time period sorted by network. This 
build also provides changes that improve dispatch of long (240+ character) 
messages submitted using TAP (Telocator Alphanumeric Protocol) via modem 
dial-up connection to Sprint. Finally, a cosmetic change in PageMate Client and 
PageMate Administrator GUI changes the default menubar height for select 
screen resolutions. 

PageMate Classic Server. Build 121220 fixes in PageMate Classic Sever a 
problem that was preventing messages to groups from being delivered to the 
second and subsequent members of the group. This build also provides 
changes that improve dispatch of long (240+ character) messages submitted 
using TAP (Telocator Alphanumeric Protocol) via modem dial-up connection to 
Sprint. Finally, a cosmetic change in PageMate Client and PageMate 
Administrator GUI changes the default menubar height for select screen 
resolutions. 

PageMate Client. Build 121220 provides a cosmetic change in PageMate Client 
GUI that changes the default menubar height for select screen resolutions. 

130208 Builds of PageMate Automated Messenger Server for Windows dated on or after 
8 February 2013 include a fix for a problem that can stall execution of 
PageMate Server indefinitely as it tries to send a message to a group member 
that has been deleted from the subscriber catalog. This is a critical fix that 
should be installed by any site that is running any prior build of PAM Server 
V3.3-0. 

130214 Builds of PageMate Automated Messenger Server for Windows dated on or after 
14 February 2013 include a fix for a problem with wildcard lookups of 
subscriber records. In prior builds of this version, PageMate Server was 
returning only the first subscriber record in the catalog, rather than any and all 
records matching the record search criteria. 
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Build Description of Change 

130220 Builds of PageMate Automated Messenger Server for Windows dated on or after 
20 February 2013 include a fix in PageMate Administrator GUI for proper 
display of options for RPC Protocol Type in Windows native GUI dialogs used 
for add and edit servers and sites 

This build also includes changes in functionality for data validation used in 
conjunction with add and edit groups in the PageMate Web Connector and 
COM+ interface. In earlier builds of PAM Server V3.3-0, defects in data 
validation code could result in corruption of the groups catalog as a result of an 
attempt to update the groups catalog with invalid or unlisted member names 
passed via the COM+ interface by site-specific applications. Build 130220 
strengthens data validation operations, corrects inadequacies in the code, and 
provides a new site-specific option to specify how PageMate should handle 
attempts to add or edit group records that include one or more invalid or 
unlisted member names. Examples of operations with invalid or unlisted names 
include attempts to add a new group or edit an existing group to include a 
blank name or a name that is not the name of either a subscriber or another 
group. 

By default, when a site-specific application operating via the COM+ interface 
attempts to add or update a group catalog record specifying a group member 
name that is invalid or unlisted, PageMate will ignore the invalid or unlisted 
name, provide notice to the PamComSrv.log file, and continue processing with 
names that are valid. At the conclusion of the add or update operation, success 
status will be returned to the site-specific application if at least one member of 
the group was added or updated successfully. This might not be the action that 
a site-specific application would prefer, however, because it could leave the 
application thinking it has added a member name to a group when the name 
was, in fact, not added because it failed validation. 

In PAM Server V3.3-0 Build 130220 and later, if Registry key FAIL_UNLISTED is 
provided with value TRUE in the PageMate\Server hive, COM+ programmed 
operations that attempt add or update operations that fail validation will fail 
completely and return FAIL status. In this case, the add or update operation will 
not be performed, and notice of the failure will be provided both in the 
PamComSrv.log file and in the status returned to the site-specific application. 

130225 Builds of PageMate Automated Messenger Server and PageMate Client for 
Windows dated on or after 25 February 2013 include new functionality for 
MOTOTRBO radio users. A new completion status for MTMP messages is now 
supported to indicate that a message addressed to a MOTOTRBO radio has 
been received and displayed on the screen of the recipient radio. Additional 
information about this functionality is provided in Change History Notes for 
Build 130225. 
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Build Description of Change 

130406 Builds of PageMate Automated Messenger Server for Windows dated on or after 
6 April 2013 include support for a new Registry key, SMGP_SERVICE_ID, that 
can be used to specify ServiceID, an optional parameter for SMGP protocol. 
SMGP is a proprietary protocol of China Telecom.  

This build also includes changes in the implementation of support for CCOM 
(Cellcom) protocol to fix problems with posting completion status for SMS 
messages submitted via CCOM. In earlier builds, some messages that were 
successfully dispatched were being assigned a completion status indicating that 
they had failed. 

Builds of PageMate Server for Windows dated on or after 6 April 2013 also 
implement a new operational constraint that disallows Show Current Queue 
functionality in PageMate Administrator when debug logging (DEBUG Registry 
key) is enabled. 

130720 Builds of PageMate Automated Messenger Server for Windows dated on or after 
20 July 2013 include a change in the way Queue Mutex Timeout works for 
SNPP messages. In earlier builds, Queue Mutex Timeout for SNPP messages 
was hard-coded at 5 seconds, while all protocols other than SNPP used the 
value provided by the QUEUE_MUTEX_TIMEOUT Registry key. In Build 
130720 and later, SNPP messages use the value provided via the 
QUEUE_MUTEX_TIMEOUT Registry key. The QUEUE_MUTEX_TIMEOUT 
Registry key has a default value of 5 (seconds), but can be set to a site-specific 
value in the range 3-30 (seconds). Queue Mutex Timeout places a limit on the 
amount of time the PageMate Queue Server will wait for access to the message 
queue when submitting a message. 

Builds of PageMate Server (both Classic and PAM) dated on or after 20 July 
2013 also include a bug fix in code that is responsible for selecting a NIC 
(based on the specification of Local Port Address in a PageMate network 
catalog record with socket Connection Type) to be used for an outbound 
network connection on a PageMate server that has more than one NIC. 
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Build Description of Change 

131101 Builds of PageMate Automated Messenger Server for Windows dated on or after 
1 November 2013 include a fix for a problem with the delivery of e-mail 
messages under profiles. In earlier builds of this program and version, Registry 
specification of SMTP_GATEWAY was not being honored in code responsible 
for SMTP message delivery under profiles when EMAIL_SERVICE was LOCAL.  

This build also corrects a problem with processing of inbound SMTP messages 
in the Electronic Mail Connector. In earlier builds of this program and version, 
the status parameter in subscriber catalog records was not being honored by 
the Electronic Mail Connector. 

Build 131101 also corrects a problem with propagation of group catalog records 
between catalog masters and slaves. In earlier builds of this program and 
version, a catalog slave could corrupt the group catalog file (on the slave 
server) during the process of updating a group catalog record. 

Finally, the PageMate Administrator GUI now displays the message “Function 
not supported with DEBUG enabled” if a display of the current page message 
queue (View>Queue>Page) is requested when DEBUG logging is enabled. In 
earlier builds of this program and version, an empty dialog was displayed, 
suggesting that there were no messages in the queue when, in fact, the report 
may have been empty because the Queue Server had refused the request from 
PageMate Administrator to provide the data. The new message dialog is 
provided to let you know that no data is being displayed because the Queue 
Server has refused the request. In the absence of this dialog, an empty report 
now does, in fact, mean that there are no messages in the queue. 

A request from PageMate Administrator GUI to display the current message 
queue interrupts operation of the queue in proportion to the number of 
messages in the queue. Because PageMate’s primary responsibility is serving 
messages from the queue, administrative requests for reporting information take 
a back seat relative to this responsibility. For this reason, there are several 
constraints on interactive reporting via PageMate Administrator. One constraint, 
as described here, is that View>Queue>Page is not supported when DEBUG 
logging is enabled. Another constraint is that in the absence of DEBUG logging, 
the Queue Server will honor requests to display or refresh the display of queue 
information no more frequently than once every 10 seconds. So clicking the 
“Refresh” button in a View>Queue>Page dialog any more frequently than once 
every 10 seconds will have no effect. In the absence of requests to refresh the 
display, a running View>Queue>Page display will be automatically refreshed 
every 30 seconds. 
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Build Description of Change 

131201 Builds of PageMate Automated Messenger Server for Windows dated on or after 
1 December 2013 include a fix for a problem in the PageMate Web Connector 
that could prevent a web client from connecting via RPC to a PageMate 
Automated Messenger Server. This build also changes the default value of 
WEB_USERNAME from IUSR_<computername> to IUSR, consistent with the 
change in anonymous account name made by Microsoft beginning with IIS 7.0. 
In this and all prior builds of PAM Server, a site-specific name for the 
anonymous web username can be defined via Registry key WEB_USERNAME in 
the PageMate\Server hive. This build also introduces changes in the website 
provided with the Web Connector, including new CSS code and support for 
native mode operation with Internet Explorer 10 and later. 

140118 Builds of PageMate Automated Messenger Server for Windows dated on or after 
18 January 2014 include a fix for a problem with export/import groups. In 
earlier builds of this version, the FORWARD record parameter was ignored. 
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